Skip to main content

Required - libcurl version

Aerospike Server 5.1+ requires the libcurl shared library. This is contained in a package whose name varies depending on the Linux distribution you are installing on.

The table below shows several common Linux distributions and the corresponding packages containing the required libcurl shared object library.

For information about how to install software packages, see your operating system's documentation.

Linux distributionlibcurl package name
amzn2libcurl
debian 8libcurl3
debian 9libcurl3
debian 10libcurl4
el7libcurl
el8libcurl-minimal
oraclelinux7libcurl
ubuntu 18.04libcurl4
ubuntu 20.04libcurl4